import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*[A-Z]+ (?:([-\\d ]+)|\"(.*)\")";
final String string = "*PATH \"C:\\Users\\User\\Desktop\\Media\\SoundBanks\\Ambient\\WAV_Data\\AD_SMP_SFX_WIND0.wav\"\n"
+ "*NODECOLOR 0 255 140\n"
+ "*FILEREF -7\n"
+ "*FREQUENCY 22050";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}