// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\*[A-Z]+ (?:([-\d ]+)|"(.*)")"#).unwrap();
let string = "*PATH \"C:\\Users\\User\\Desktop\\Media\\SoundBanks\\Ambient\\WAV_Data\\AD_SMP_SFX_WIND0.wav\"
*NODECOLOR 0 255 140
*FILEREF -7
*FREQUENCY 22050";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}