re = /\*[A-Z]+ (?:([-\d ]+)|"(.*)")/m
str = '*PATH "C:\\Users\\User\\Desktop\\Media\\SoundBanks\\Ambient\\WAV_Data\\AD_SMP_SFX_WIND0.wav"
*NODECOLOR 0 255 140
*FILEREF -7
*FREQUENCY 22050'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end