const regex = /\*[A-Z]+ (?:([-\d ]+)|"(.*)")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*[A-Z]+ (?:([-\\d ]+)|"(.*)")', 'gm')
const str = `*PATH "C:\\Users\\User\\Desktop\\Media\\SoundBanks\\Ambient\\WAV_Data\\AD_SMP_SFX_WIND0.wav"
*NODECOLOR 0 255 140
*FILEREF -7
*FREQUENCY 22050`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}