$re = '/\*[A-Z]+ (?:([-\d ]+)|"(.*)")/m';
$str = '*PATH "C:\\Users\\User\\Desktop\\Media\\SoundBanks\\Ambient\\WAV_Data\\AD_SMP_SFX_WIND0.wav"
*NODECOLOR 0 255 140
*FILEREF -7
*FREQUENCY 22050';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);