#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!')([^']+)?on error goto"
Local $sString = "on error goto" & @CRLF & _
"on error goto" & @CRLF & _
" on error goto" & @CRLF & _
" on error goto" & @CRLF & _
"'on error goto" & @CRLF & _
"' on error goto" & @CRLF & _
"if aap =0 then on error goto errorhandler4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")