using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!')([^']+)?on error goto";
string input = @"on error goto
on error goto
on error goto
on error goto
'on error goto
' on error goto
if aap =0 then on error goto errorhandler4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}