const regex = /^(?!')([^']+)?on error goto/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\')([^\']+)?on error goto', 'gm')
const str = `on error goto
on error goto
on error goto
on error goto
'on error goto
' on error goto
if aap =0 then on error goto errorhandler4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}