re = /^(?!')([^']+)?on error goto/m
str = 'on error goto
on error goto
on error goto
on error goto
\'on error goto
\' on error goto
if aap =0 then on error goto errorhandler4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end