$re = '/^(?!\')([^\']+)?on error goto/m';
$str = 'on error goto
on error goto
on error goto
on error goto
\'on error goto
\' on error goto
if aap =0 then on error goto errorhandler4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);