using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s?\d{1,2}\s+[\w-]+\s+\w+]\s[[(]\s([\w\s]+)[\s*][)\]]\s(\(WANTED\)\s)?([\w\']+)";
string input = @"[51 Hu-man Skd] [ White Robes*] (WANTED) Maccus Stormbound Overlord of the DreadPirates ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}