package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s?\d{1,2}\s+[\w-]+\s+\w+]\s[[(]\s([\w\s]+)[\s*][)\]]\s(\(WANTED\)\s)?([\w\']+)`)
var str = `[51 Hu-man Skd] [ White Robes*] (WANTED) Maccus Stormbound Overlord of the DreadPirates `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}