re = /\[\s?\d{1,2}\s+[\w-]+\s+\w+]\s[[(]\s([\w\s]+)[\s*][)\]]\s(\(WANTED\)\s)?([\w\']+)/m
str = '[51 Hu-man Skd] [ White Robes*] (WANTED) Maccus Stormbound Overlord of the DreadPirates '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end