// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\s?\d{1,2}\s+[\w-]+\s+\w+]\s[[(]\s([\w\s]+)[\s*][)\]]\s(\(WANTED\)\s)?([\w\']+)").unwrap();
let string = "[51 Hu-man Skd] [ White Robes*] (WANTED) Maccus Stormbound Overlord of the DreadPirates ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}