import Foundation
let pattern = #"\[\s?\d{1,2}\s+[\w-]+\s+\w+]\s[[(]\s([\w\s]+)[\s*][)\]]\s(\(WANTED\)\s)?([\w\']+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[51 Hu-man Skd] [ White Robes*] (WANTED) Maccus Stormbound Overlord of the DreadPirates "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)