#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div id=\"[^"]+?\" style=[^>]+?>(\s|\n|[^\n]{,5})<\/div>"
Local $sString = "" & @CRLF & _
"<div id="page126-div" style="position:relative;width:918px;height:1188px;">" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div id="page127-div" style="position:relative;width:918px;height:1188px;">" & @CRLF & _
"sometext for example" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div id="page128-div" style="position:relative;width:918px;height:1188px;">" & @CRLF & _
"</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")