const regex = /<div id=\"[^"]+?\" style=[^>]+?>(\s|\n|[^\n]{,5})<\/div>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div id=\\"[^"]+?\\" style=[^>]+?>(\\s|\\n|[^\\n]{,5})<\\\/div>', 'g')
const str = `
<div id="page126-div" style="position:relative;width:918px;height:1188px;">
</div>
<div id="page127-div" style="position:relative;width:918px;height:1188px;">
sometext for example
</div>
<div id="page128-div" style="position:relative;width:918px;height:1188px;">
</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}