re = /<div id=\"[^"]+?\" style=[^>]+?>(\s|\n|[^\n]{,5})<\/div>/
str = '
<div id="page126-div" style="position:relative;width:918px;height:1188px;">
</div>
<div id="page127-div" style="position:relative;width:918px;height:1188px;">
sometext for example
</div>
<div id="page128-div" style="position:relative;width:918px;height:1188px;">
</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end