package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div id=\"[^"]+?\" style=[^>]+?>(\s|\n|[^\n]{,5})<\/div>`)
var str = `
<div id="page126-div" style="position:relative;width:918px;height:1188px;">
</div>
<div id="page127-div" style="position:relative;width:918px;height:1188px;">
sometext for example
</div>
<div id="page128-div" style="position:relative;width:918px;height:1188px;">
</div>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}