// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div id=\"[^"]+?\" style=[^>]+?>(\s|\n|[^\n]{,5})<\/div>"#).unwrap();
let string = "
<div id=\"page126-div\" style=\"position:relative;width:918px;height:1188px;\">
</div>
<div id=\"page127-div\" style=\"position:relative;width:918px;height:1188px;\">
sometext for example
</div>
<div id=\"page128-div\" style=\"position:relative;width:918px;height:1188px;\">
</div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}