# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b[A-Za-z0-9]{3,4}\s[A-Za-z0-9]{3}\b)/$1 $2/gm;t' <<< "STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB
BOW STREET, LONDON, WC2E 7AH
STATION ROAD, LONDON SE20 7BQ
Station road London SE20 7BQ UK=
Station road London SE20 7BQ UK
Station Road Penge SE20 7BQ London
Station Road SE20 7BQ London
"