import Foundation
let pattern = #"(\b[A-Za-z0-9]{3,4}\s[A-Za-z0-9]{3}\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB
BOW STREET, LONDON, WC2E 7AH
STATION ROAD, LONDON SE20 7BQ
Station road London SE20 7BQ UK=
Station road London SE20 7BQ UK
Station Road Penge SE20 7BQ London
Station Road SE20 7BQ London
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)