// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b[A-Za-z0-9]{3,4}\s[A-Za-z0-9]{3}\b)").unwrap();
let string = "STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB
BOW STREET, LONDON, WC2E 7AH
STATION ROAD, LONDON SE20 7BQ
Station road London SE20 7BQ UK=
Station road London SE20 7BQ UK
Station Road Penge SE20 7BQ London
Station Road SE20 7BQ London
";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}