use strict;
my $str = 'STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB
BOW STREET, LONDON, WC2E 7AH
STATION ROAD, LONDON SE20 7BQ
Station road London SE20 7BQ UK=
Station road London SE20 7BQ UK
Station Road Penge SE20 7BQ London
Station Road SE20 7BQ London
';
my $regex = qr`(\b[A-Za-z0-9]{3,4}\s[A-Za-z0-9]{3}\b)`mp;
my $subst = '$1 $2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";