#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Initial commit|Merge [^\r\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\(\w+\))?!?: ([\w ]+))(?:\r?\n){0,2}([\w\s]+)(?:\r?\n([\w-]+): (\w+)|$)"
Local $sString = "#1" & @CRLF & _
"" & @CRLF & _
"build(Breaking): la asdf asdf asdf" & @CRLF & _
"" & @CRLF & _
"asdfasdf asdf asdf" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"aef asdf asdf" & @CRLF & _
"" & @CRLF & _
"#2" & @CRLF & _
"" & @CRLF & _
"build(Breaking): la asdf asdf asdf" & @CRLF & _
"" & @CRLF & _
"asdfasdf asdf asdf" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"asdf" & @CRLF & _
"" & @CRLF & _
"aef asdf asdf" & @CRLF & _
"" & @CRLF & _
"asdf-asdf: asdf" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")