import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Initial commit|Merge [^\\r\\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\\(\\w+\\))?!?: ([\\w ]+))(?:\\r?\\n){0,2}([\\w\\s]+)(?:\\r?\\n([\\w-]+): (\\w+)|$)";
final String string = "#1\n\n"
+ "build(Breaking): la asdf asdf asdf\n\n"
+ "asdfasdf asdf asdf\n"
+ "asdf\n"
+ "asdf\n"
+ "asdf\n\n"
+ "asdf\n"
+ "asdf\n\n"
+ "asdf\n\n"
+ "aef asdf asdf\n\n"
+ "#2\n\n"
+ "build(Breaking): la asdf asdf asdf\n\n"
+ "asdfasdf asdf asdf\n"
+ "asdf\n"
+ "asdf\n"
+ "asdf\n\n"
+ "asdf\n"
+ "asdf\n\n"
+ "asdf\n\n"
+ "aef asdf asdf\n\n"
+ "asdf-asdf: asdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}