import re
regex = re.compile(r"Initial commit|Merge [^\r\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\(\w+\))?!?: ([\w ]+))(?:\r?\n){0,2}([\w\s]+)(?:\r?\n([\w-]+): (\w+)|$)", flags=re.MULTILINE)
test_str = ("#1\n\n"
"build(Breaking): la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n\n"
"#2\n\n"
"build(Breaking): la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n\n"
"asdf-asdf: asdf\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")