const regex = /Initial commit|Merge [^\r\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\(\w+\))?!?: ([\w ]+))(?:\r?\n){0,2}([\w\s]+)(?:\r?\n([\w-]+): (\w+)|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Initial commit|Merge [^\\r\\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\\(\\w+\\))?!?: ([\\w ]+))(?:\\r?\\n){0,2}([\\w\\s]+)(?:\\r?\\n([\\w-]+): (\\w+)|$)', 'gm')
const str = `#1
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
#2
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
asdf-asdf: asdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}