re = /Initial commit|Merge [^\r\n]+|(?:(build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(\(\w+\))?!?: ([\w ]+))(?:\r?\n){0,2}([\w\s]+)(?:\r?\n([\w-]+): (\w+)|$)/m
str = '#1
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
#2
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
asdf-asdf: asdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end