#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(?:(^|,)(?i:[а-яё]()|[^,])*+(?!\2))+,?"
Local $sString = "42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you've done 4 times, pose 74, рисунок 12" & @CRLF & _
"привет, bobby, частота кадра 60fps, привет,"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)