use strict;
my $str = '42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you\'ve done 4 times, pose 74, рисунок 12
привет, bobby, частота кадра 60fps, привет,';
my $regex = qr~(?:(^|,)(?i:[а-яё]()|[^,])*+(?!\2))+,?~up;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";