const regex = new RegExp('(?:(^|,)(?i:[а-яё]()|[^,])*+(?!\\2))+,?', 'gu')
const str = `42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you've done 4 times, pose 74, рисунок 12
привет, bobby, частота кадра 60fps, привет,`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);