import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?:(^|,)(?i:[а-яё]()|[^,])*+(?!\2))+,?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you've done 4 times, pose 74, рисунок 12
привет, bobby, частота кадра 60fps, привет,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)