import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:TCP|UDP)\\/\\d+(?:-\\d+)?(?:,(?:TCP|UDP)\\/\\d+(?:-\\d+)?)*$";
final String string = "TCP/53,UDP/53,TCP/10-20,UDP/20-30\n\n"
+ "TCP/53UDP53,TCP/10-20UDP20-30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}