import re
regex = re.compile(r"^(?:TCP|UDP)\/\d+(?:-\d+)?(?:,(?:TCP|UDP)\/\d+(?:-\d+)?)*$", flags=re.MULTILINE)
test_str = ("TCP/53,UDP/53,TCP/10-20,UDP/20-30\n\n"
"TCP/53UDP53,TCP/10-20UDP20-30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")