const regex = /^(?:TCP|UDP)\/\d+(?:-\d+)?(?:,(?:TCP|UDP)\/\d+(?:-\d+)?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:TCP|UDP)\\\/\\d+(?:-\\d+)?(?:,(?:TCP|UDP)\\\/\\d+(?:-\\d+)?)*$', 'gm')
const str = `TCP/53,UDP/53,TCP/10-20,UDP/20-30
TCP/53UDP53,TCP/10-20UDP20-30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}