$re = '/^(?:TCP|UDP)\/\d+(?:-\d+)?(?:,(?:TCP|UDP)\/\d+(?:-\d+)?)*$/m';
$str = 'TCP/53,UDP/53,TCP/10-20,UDP/20-30
TCP/53UDP53,TCP/10-20UDP20-30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);