using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:if(\W+)(\d+)-)?(\d+\.?\d*)([%$])";
string input = @"2.3%
3.5%
if>=100000-1.6%,if<100000-100$
if>=100000-1.6%,if<100000-100$
500$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}