import re
regex = re.compile(r"(?:if(\W+)(\d+)-)?(\d+\.?\d*)([%$])", flags=re.MULTILINE)
test_str = ("2.3%\n"
"3.5%\n"
"if>=100000-1.6%,if<100000-100$\n"
"if>=100000-1.6%,if<100000-100$\n"
"500$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")