re = /(?:if(\W+)(\d+)-)?(\d+\.?\d*)([%$])/m
str = '2.3%
3.5%
if>=100000-1.6%,if<100000-100$
if>=100000-1.6%,if<100000-100$
500$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end