using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<PROD_NAME>.*?)\s*(?P<Weight>\d+g)$";
string input = @"CNatural Chip Compny SeaSalt 175g
Smiths Crinkle Cut Chips Chicken170g";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}