package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<PROD_NAME>.*?)\s*(?P<Weight>\d+g)$`)
var str = `CNatural Chip Compny SeaSalt 175g
Smiths Crinkle Cut Chips Chicken170g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}