// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<PROD_NAME>.*?)\s*(?P<Weight>\d+g)$").unwrap();
let string = "CNatural Chip Compny SeaSalt 175g
Smiths Crinkle Cut Chips Chicken170g";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}