$re = '/^(?P<PROD_NAME>.*?)\s*(?P<Weight>\d+g)$/m';
$str = 'CNatural Chip Compny SeaSalt 175g
Smiths Crinkle Cut Chips Chicken170g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);