re = /^(?P<PROD_NAME>.*?)\s*(?P<Weight>\d+g)$/m
str = 'CNatural Chip Compny SeaSalt 175g
Smiths Crinkle Cut Chips Chicken170g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end