import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/www\\.example\\.com\\/.*foo";
final String string = "http://www.example.com/pages/\n"
+ "http://www.example.com/pages/bar\n\n"
+ "http://www.example.com/pages/foo/bar.html\n"
+ "http://www.example.com/pages/test-foo-test.html\n"
+ "http://www.example.com/pages/foo.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}