$re = '/http:\/\/www\.example\.com\/.*foo/m';
$str = 'http://www.example.com/pages/
http://www.example.com/pages/bar
http://www.example.com/pages/foo/bar.html
http://www.example.com/pages/test-foo-test.html
http://www.example.com/pages/foo.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);