const regex = /http:\/\/www\.example\.com\/.*foo/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/www\\.example\\.com\\\/.*foo', 'gm')
const str = `http://www.example.com/pages/
http://www.example.com/pages/bar
http://www.example.com/pages/foo/bar.html
http://www.example.com/pages/test-foo-test.html
http://www.example.com/pages/foo.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}