re = /http:\/\/www\.example\.com\/.*foo/m
str = 'http://www.example.com/pages/
http://www.example.com/pages/bar
http://www.example.com/pages/foo/bar.html
http://www.example.com/pages/test-foo-test.html
http://www.example.com/pages/foo.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end