import re
regex = re.compile(r"http:\/\/www\.example\.com\/.*foo", flags=re.MULTILINE)
test_str = ("http://www.example.com/pages/\n"
"http://www.example.com/pages/bar\n\n"
"http://www.example.com/pages/foo/bar.html\n"
"http://www.example.com/pages/test-foo-test.html\n"
"http://www.example.com/pages/foo.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")